15 Replies Latest reply on Jan 11, 2017 1:14 PM by wroot

    spark error in the first logon

    Skatalitico

      When spark starts up allways shows the next error, my openfire version is 4.1.1 and this error is happening since 3 versions ago of the openfire, and the spark version is 2.8.2 Build 934 and my java version is 8 version 111, it's making me crazy to me and to all my users.

       

      java.lang.ExceptionInInitializerError

        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

        at java.lang.reflect.Constructor.newInstance(Unknown Source)

        at java.lang.Class.newInstance(Unknown Source)

        at org.jivesoftware.launcher.Startup.start(Startup.java:83)

        at org.jivesoftware.launcher.Startup.main(Startup.java:43)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

        at java.lang.reflect.Method.invoke(Unknown Source)

        at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:65)

        at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:101)

        at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:26)

      Caused by: java.lang.NullPointerException

        at java.io.File.<init>(Unknown Source)

        at org.jivesoftware.Spark.initializeDirectory(Spark.java:97)

        at org.jivesoftware.Spark.getLogDirectory(Spark.java:405)

        at org.jivesoftware.spark.util.log.Log.<init>(Log.java:54)

        at org.jivesoftware.spark.util.log.Log.getInstance(Log.java:46)

        at org.jivesoftware.spark.util.log.Log.error(Log.java:108)

        at org.jivesoftware.spark.util.UIComponentRegistry.instantiate(UIComponentRegistry .java:509)

        at org.jivesoftware.spark.util.UIComponentRegistry.createChatContainer(UIComponent Registry.java:458)

        at org.jivesoftware.spark.ChatManager.<init>(ChatManager.java:133)

        at org.jivesoftware.spark.ChatManager.getInstance(ChatManager.java:120)

        at org.jivesoftware.spark.SparkManager.getChatManager(SparkManager.java:202)

        at org.jivesoftware.SparkStartupListener.startupPerformed(SparkStartupListener.jav a:34)

        at com.install4j.api.launcher.StartupNotification$ListenerAdapter.startupPerformed (StartupNotification.java:103)

        at com.exe4j.Controller.registerStartupListener(Controller.java:74)

        at com.install4j.api.launcher.StartupNotification.registerStartupListener(StartupN otification.java:37)

        at org.jivesoftware.Spark.<clinit>(Spark.java:291)

        ... 14 more

        • Re: spark error in the first logon
          wroot

          Is this error appearing in the logs or do you really see it somewhere when logging into Spark? if not, what error does Spark shows to the users? It probably will be the same, but you can try Java 112 version.

            • Re: spark error in the first logon
              Skatalitico

              It appears as soon as the spark is opened and try to do the autologin, and its the same error for everyone, i've tried with differents versions of java, the 111 is the last one, but happens only in the morning when is the first time logon, when i try to login again after the error, works normally.

                • Re: spark error in the first logon
                  wroot

                  111 and 112 are released at the same time. Even numbered versions (112 in this case) have a bit more fixes/changes. Though i think it should work the same with 111. So you are using online installer for Spark and install Java separately? Can you try full installer of Spark?

                  • Re: spark error in the first logon
                    wroot

                    Are you using roaming profiles or some sort of profile redirection/virtualization. What OS on the computers? Is ti showing the same error or something else in the logs? C:\Users\username\AppData\Roaming\Spark\Logs

                      • Re: spark error in the first logon
                        speedy

                        It looks like the error is being caused because spark can't access either %appdata% (on windows) or the users home folder. 

                        I'm unable to reproduce this. Could be an environment related issue. maybe network/folder redirection or maybe antivirus? Have you tried to you disable antivirus before your first start to rule that out?

                        • Re: spark error in the first logon
                          Skatalitico

                          thanks wrrot for your help, no i'm not using roaming profiles, i'm redirecting only the documents folder to the D drive, im using windows 8.1

                           

                          this is my log from yesterday

                           

                          ene 05, 2017 11:03:09 AM org.jivesoftware.spark.util.log.Log error

                          GRAVE:

                          org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPPError: not-acceptable - modify

                            at org.jivesoftware.smack.XMPPException$XMPPErrorException.ifHasErrorThenThrow(XMP PException.java:135)

                            at org.jivesoftware.smack.PacketCollector.nextResultOrThrow(PacketCollector.java:2 32)

                            at org.jivesoftware.smack.PacketCollector.nextResultOrThrow(PacketCollector.java:2 13)

                            at org.jivesoftware.smack.roster.Roster.removeEntry(Roster.java:525)

                            at org.jivesoftware.spark.ui.ContactList.lambda$addSubscriptionListener$16(Contact List.java:1826)

                            at org.jivesoftware.smack.AbstractXMPPConnection$3.run(AbstractXMPPConnection.java :1106)

                            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

                            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

                            at java.lang.Thread.run(Unknown Source)

                           

                          Deleted excessive log - wroot

                            • Re: spark error in the first logon
                              wroot

                              Skatalitico wrote:

                               

                              i'm redirecting only the documents folder to the D drive

                              What is your downloads target folder in Spark preferences? File > Preferences > File transfer. Maybe it is pointing to some folder in Documents and then it might cause problems with redirection. If so, you can try changing it to some other local folder and test with it.

                               

                              P.S. next time just attach the log as a file, so it won't take so much space