27 Replies Latest reply on May 31, 2014 8:58 AM by Bodhisatwa Bhattacharya

    OpenFire 3.7.0 - FastPath WebChat not installing?

    nathanc Bronze

      Howdy -

      I've been running Openfire 3.6.4 for over a year with the Fastpath Service (4.1) and Fastpath Webchat (4.0) running flawlessly.

      That system is running Windows 2003 with the embedded database


      I am going to consolidate systems across the organization and wanted to move Openfire to version 3.7 and use a MSSQL 2008 backend.

      I installed the database on a Windows 2008 x64 | MSSQL 2008 system with no trouble.


      I installed a clean front-end of the latest version (3.7) on a different Windows 2008 x64 system and again - everything works fine - LDAP integration, etc...


      The trouble comes when I attempt to install the Fastpath Webchat plug-in. The Fastpath Service installs fine, but the Webchat plug-in appears to install but never 'leaves' the Available Plug-Ins page (but the green + / check do not appear either) and it never appears in the installed plug-ins page either.


      I have done a lot of searching but hopefully I am just missing something - I attempted to manually load the .war file found in this post:


        - that didn't work either.


      I've also tried a different version of plugins_webchat.war and that didn't work either.


      I'm at a loss at this point and sad because I don't want to remain with my current setup indefinitely.


      Thank you for any assistance,

        • OpenFire 3.7.0 - FastPath WebChat not installing?
          nathanc Bronze

          I resolved the error above by verifying my Java install

          But - not when I click the Tools link in the Fastpath tab I get this error:


          HTTP ERROR 404
          Problem accessing /webchat. Reason:


               Not Found


          Powered by Jetty://



          Not sure what the problemo is here - webchat folder exists, start.jsp is in the folder, permissions are granted to the folder.

            • OpenFire 3.7.0 - FastPath WebChat not installing?
              wroot KeyContributor
              1 of 1 people found this helpful
                • Re: OpenFire 3.7.0 - FastPath WebChat not installing?
                  nathanc Bronze

                  Thank you very much - I had not seen that thread. I applied the updated webchat.war and see that it displays as version 4.0.2 now - however, now I get:


                  HTTP ERROR: 503
                  Problem accessing /webchat. Reason:

                       Service Unavailable


                  I assume that the .patch file was informational and that the attached .war file is the compiled version that integrates the patch?

                    • Re: OpenFire 3.7.0 - FastPath WebChat not installing?
                      wroot KeyContributor

                      Yep. You should try the war file.

                        • Re: OpenFire 3.7.0 - FastPath WebChat not installing?
                          nathanc Bronze

                          Yeah - I got that far and just the Service Unavailable message now when I click the Tools link.
                          Shouldn't be a port or firewall issue since I have not changed anything from the default configuration and I have disabled the firewall to see if that was causing any trouble.


                          Nothing in the error.log file, but in the warn.log file I see the following:



                          2011.04.22 14:40:12 Committed before 404 null

                          2011.04.22 14:40:12 /webchat

                          at org.eclipse.jetty.server.Response.resetBuffer(Response.java:1047)

                                    at org.eclipse.jetty.server.Response.sendError(Response.java:265)

                                    at org.eclipse.jetty.server.Response.sendError(Response.java:367)

                                    at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpServletResponseWrap per.java:128)

                                    at com.opensymphony.module.sitemesh.filter.PageResponseWrapper.sendError(PageRespo nseWrapper.java:175)

                                    at org.eclipse.jetty.servlet.DefaultServlet.doGet(DefaultServlet.java:451)

                                    at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)

                                    at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

                                    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:530)

                                    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1216)

                                    at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

                                    at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

                                    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1187)

                                    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:425)

                                    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)

                                    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:494)

                                    at org.eclipse.jetty.server.session.SessionHandler.handle(SessionHandler.java:182)

                                    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:93 3)

                                    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:362)

                                    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:867 )

                                    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)

                                    at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandler Collection.java:245)

                                    at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.jav a:126)

                                    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:113)

                                    at org.eclipse.jetty.server.Server.handle(Server.java:334)

                                    at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:559)

                                    at org.eclipse.jetty.server.HttpConnection$RequestHandler.headerComplete(HttpConne ction.java:992)

                                    at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:541)

                                    at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:203)

                                    at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:406)

                                    at org.eclipse.jetty.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:4 62)

                                    at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:436)

                                    at java.lang.Thread.run(Unknown Source)

                  • OpenFire 3.7.0 - FastPath WebChat not installing?
                    Gajendra Bronze

                    HI frnds,


                    I am new in opensource and i have installed openfire for testing purpose and while accessing webhcat I am getting below error



                    HTTP ERROR 404

                    Problem accessing /webchat. Reason:

                        Not Found


                    Using openfire : 3.7.0

                    fastchat : 4.2.0


                    PLease help me out

                    • Re: OpenFire 3.7.0 - FastPath WebChat not installing?
                      Bodhisatwa Bhattacharya Bronze

                      Hi Nathan,


                      Could you please elaborate in detail the steps of installing Fastpath Webchat plugin in OpenFire version 3.9.3?


                      My requirement is to have a web chat client which will interact with the OpenFire server.


                      I am stating what I have done in doing the same:


                      First I installed OpenFire version 3.9.3 which was successfull. I am able to login to the admin panel by visiting the link

                      Then, I went to the "Available Plugins" list from under the "Plugins" menu and from there I tried to install "Fastpath Webchat" plugin version 4.0.0. A message showed that the plugin is successfully installed and it also appeared under the openfire/plugins folder on my server installation. But it never disappeared from  the Available Plugins list, nor did it appear in the installed Plugins list. Then, I tried to access the Webchat plugin using the url as mentioned in the readme file but it never materialised. I also tried to follow the other instructions as mentioned in the readme file but nothing happened. You can view the readme file from http://www.igniterealtime.org/projects/openfire/plugins/webchat/readme.html


                      Could you please help me out in this case? I am in urgent need and will be truly grateful to you.