4 Replies Latest reply: Jan 14, 2014 5:24 AM by MR QUANG

    /setup/setup-profile-settings.jsp java.lang.NullPointerException

    jexbigin

      I have been trying to install Openfire 3.6.4 for a couple of days on different systems and kept getting stuck when going to configure it to use local users with NullPointerException on /setup/setup-profile-settings.jsp .

       

      Full detail from warn.log

      2009.06.13 12:30:31 /setup/setup-profile-settings.jsp
      java.lang.NullPointerException
          at org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspSe rvice(setup_002dprofile_002dsettings_jsp.java:80)
          at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
          at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
          at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)
          at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
          at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
          at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:42)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
          at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
          at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
          at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
          at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
          at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
          at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
          at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
          at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
          at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
          at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
          at org.mortbay.jetty.Server.handle(Server.java:324)
          at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
          at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:843 )
          at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
          at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
          at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
          at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
          at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

       

      error.log is empty

       

      DB as either mysql or integrated..

      Using firefox 3.10 and 3.11 on Win 2003 x64, XP SP3, Vista Business.

      Tried different system JRE installs, 6,14, 6.13, 6.11, 5.18

      EVERYTHING produced the same error.  When the error is reached on Win 2003 openfire resets openfire.xml to the install default but I did have it install onto D:\Program Files\Openfire .  Using LDAP users on Win 2003 (AD) I had som LDAP issues but the install worked.

       

      The only way to work was to use internet explorer (or IE Tab in firefox).  This allowed the setup to finalise.  The admin console login also has issues with non IE browser.

       

      Is there anyway to use the system JRE 6.14 and firefox to do the whole install?  I have run these as administrator

       

      BTW, the .install4j\response.varfile has an invalid variable setting for windows.

       

      #install4j response file for Openfire 3.6.4
      #Sat Jun 13 12:25:49 EST 2009
      executeLauncherAction$Boolean=false
      sys.programGroup.linkDir=/usr/local/bin   <<<<< problem
      sys.languageId=en
      sys.installationDir=C\:\\Program Files\\Openfire
      sys.programGroupDir=C\:\\ProgramData\\Microsoft\\Windows\\Start Menu\\Programs\\Openfire
      sys.programGroup.enabled$Boolean=true
      sys.programGroup.allUsers$Boolean=true

       

       

       

      Brian