12 Replies Latest reply on Dec 30, 2009 4:55 AM by walley

    Can not login to Openfire since upgrade

    edisoninfo

      I upgraded to the latest version yesterday and all went well. Today I can not log into the admin console. I edited the openfire.xml file and change the setup line to false. That allowed me to go through the setup again and set a new password. But I still can not log in. How do I fix this?

        • Re: Can not login to Openfire since upgrade
          sixthring

          How long after the rerun of the setup did you wait to login?  Have you tried stopping and starting the server again?  Are there errors in the log files?

            • Re: Can not login to Openfire since upgrade
              edisoninfo

              Yes I restarted the server. Tried to login in right away and waited a few minutes. Same result. I had this problem yesterday when I upgraded and found the answer about editing the openfire.xml file in this newsgroup. That fixed it yesterday and I got logged in. Stayed logged in most of the day trying to get the Sip Phone, Spark, and Ansterisk-IM to play nice. Never succeeded but that is a different story. Today I tried to login and work some more and can not get logged in. I just tried it again and same thing. This is in the error log:

               

              <quote>

              2008.09.26 09:49:20 [org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.jav a:507)] Error loading plugin: /opt/openfire/plugins/search
              java.lang.NullPointerException: No ComponentManager implementation available.
                      at org.xmpp.component.ComponentManagerFactory.getComponentManager(ComponentManager Factory.java:53)
                      at org.jivesoftware.openfire.plugin.SearchPlugin.initializePlugin(SearchPlugin.jav a:137)
                      at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :448)
                      at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :47)
                      at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1014)
                      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
                      at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
                      at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
                      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)
                      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)
                      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)
                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
                      at java.lang.Thread.run(Unknown Source)
              2008.09.26 09:49:20 [org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.jav a:507)] Error loading plugin: /opt/openfire/plugins/sip
              java.lang.NullPointerException: No ComponentManager implementation available.
                      at org.xmpp.component.ComponentManagerFactory.getComponentManager(ComponentManager Factory.java:53)
                      at org.jivesoftware.openfire.sip.SipManager.initializePlugin(SipManager.java:53)
                      at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :448)
                      at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :47)
                      at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1014)
                      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
                      at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
                      at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
                      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)
                      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)
                      at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)
                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
                      at java.lang.Thread.run(Unknown Source)
              2008.09.26 09:49:22 [org.jivesoftware.phone.PhonePlugin$1.call(PhonePlugin.java:306)] Error enabling or disabling plugin.
              java.lang.NullPointerException: No ComponentManager implementation available.
                      at org.xmpp.component.ComponentManagerFactory.getComponentManager(ComponentManager Factory.java:53)
                      at org.jivesoftware.phone.PhonePlugin.init(PhonePlugin.java:123)
                      at org.jivesoftware.phone.PhonePlugin$1.call(PhonePlugin.java:298)
                      at org.jivesoftware.phone.PhonePlugin$1.call(PhonePlugin.java:294)
                      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
                      at java.util.concurrent.FutureTask.run(Unknown Source)
                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
                      at java.lang.Thread.run(Unknown Source)

              </quote>

            • Re: Can not login to Openfire since upgrade
              sixthring

              I am running 3.6.0a on my server with MySQL and it was done as an upgrade.  I have no issues logging in, so the statement that there is something wrong with the version as a whole is not accurate.  I am not saying there are not issues because there are.  My guess is you have an error with your upgrade.  The database may not have upgraded fully.  This does seem a common problem.  What version of MySQL are you running?  Your openfire db version my be wrong, there are directions somewhere in the forum to find this version number.