openfire 3.9.x (anything above 3.8.2 ) and mysql

Version 1

    Hi,  any time I try to use openfire 3.9  and mysql  it fails to authenticate.

     

    If it's a upgrade or even if i do a fresh install what I get in the logs is 

     

    java.sql.SQLException: Unable to load authentication plugin

     

    also I note that even in a empty database when I import openfire/resources/database/openfire_mysql.sql

     

    I get ERROR 1050 (42S01) at line 4: Table 'ofUser' already exists

     

     

    If I run 3.8.2 I dont run into these mysql issues.

     

     

    Any Pointers would be greatly appreciated.

     

    Net Nut