Skip navigation
5801 Views 10 Replies Latest reply: Feb 6, 2009 4:13 AM by wroot RSS
Javanesevn Bronze 47 posts since
Mar 25, 2008
Currently Being Moderated

Feb 3, 2009 1:11 AM

Openfire 3.6.3 enabled 9091 port?

Hi all,

 

Today, I installed new Openfire 3.6.3 version but new version is not enabled 9091 port for web console.

How can I enabled web console security?

 

Best regards,

  • wroot KeyContributor 8,288 posts since
    Jan 24, 2005
    Currently Being Moderated
    Feb 3, 2009 4:58 AM (in response to Javanesevn)
    Re: Openfire 3.6.3 enabled 9091 port?

    Are you able to login with 9090 port? What do you see on the start page then? Is 9091 listed in the list of ports? Maybe there is an exclamation icon saying about something is wrong. Maybe you have deleted your certificates while updating Openfire. Then you can try to generate or add them again.

      • wroot KeyContributor 8,288 posts since
        Jan 24, 2005
        Currently Being Moderated
        Feb 3, 2009 10:05 AM (in response to Javanesevn)
        Re: Openfire 3.6.3 enabled 9091 port?

        If you see such picture when you login to 9090 port:

         

        op_cert_error.jpg

         

        Then you have probably overwritten your certificate keystore when you were extracting the new version (/openfire/resources/security/ dir). You should make a backup of that dir before upgrading and then copy your backup on top of the newly written files. Now you have to go to Server Settings > Server Certificate and import your existing certificate or generate a self-signed one (less secure). Then you shall see 9091 port listed and you'll be able to login to port 9091.

         

        op_9091_port.jpg

        • wroot KeyContributor 8,288 posts since
          Jan 24, 2005
          Currently Being Moderated
          Feb 3, 2009 10:27 AM (in response to wroot)
          Re: Openfire 3.6.3 enabled 9091 port?

          In your case the icon will rather be like this:

           

          op_cert_error2.jpg


          Such icon will be shown with the default certificates keystore after the upgrade. In my first example the icon was about the corrupted keystore.

            • wroot KeyContributor 8,288 posts since
              Jan 24, 2005
              Currently Being Moderated
              Feb 3, 2009 11:35 PM (in response to Javanesevn)
              Re: Openfire 3.6.3 enabled 9091 port?

              Have you tried to click on that link to restart http server? The same result should be after restarting the Openfire. In you screenshots i see that certificates are in place and clients can already use them (icons with a lock), but 9091 is not showing up. 9091 is related to Openfire's internal http server, so http server should be restarted.

               

              Also, can you tell what files do you see in /openfire/resources/security ?

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points